


<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Charmer - Ivy | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/review/17120/charmer-ivy"/>
  <meta name="description" content="Michigan's Charmer are another of those Midwest-emo bands that I wouldn't say are part of any revival or whatever, as that ship has sailed. But what I would say is they're helping evolve the indie-rock-emo trifecta which bands like Tiny Moving Parts and The Hotelier have pushed over the years. And w..."/>
  <link rel="amphtml" href="https://www.punknews.org/amp/review/17120/charmer-ivy"/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Charmer - Ivy"/>
  <meta property="twitter:title" content="Charmer - Ivy"/>
  <meta property="og:url" content="https://www.punknews.org/review/17120/charmer-ivy"/>
  <meta property="twitter:url" content="https://www.punknews.org/review/17120/charmer-ivy"/>
<meta property="og:type" content="album"/>
<meta property="og:description" content="Michigan's Charmer are another of those Midwest-emo bands that I wouldn't say are part of any revival or whatever, as that ship has sailed. But what I would say is they're helping evolve the indie-rock-emo trifecta which bands like Tiny Moving Parts and The Hotelier have pushed over the years. And w..."/>
<meta property="twitter:description" content="Michigan's Charmer are another of those Midwest-emo bands that I wouldn't say are part of any revival or whatever, as that ship has sailed. But what I would say is they're helping evolve the indie-rock-emo trifecta which bands like Tiny Moving Parts and The Hotelier have pushed over the years. And w..."/>
  <meta property="og:image" content="https://static.punknews.org/images/covers/charmer-ivy.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/covers/charmer-ivy.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
        <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "Review",
        "itemReviewed": {
          "@type": "MusicAlbum",
          "byArtist": {
             "@type": "MusicGroup",
            "name": "Charmer"
          },
          "name": "Ivy"
        },
        "reviewRating": {
          "@type": "Rating",
          "ratingValue": "8",
          "bestRating": "10",
          "worstRating": "1"

        },
         "author": {
          "@type": "Person",
          "name": "RENALDO69"
        },
        "headline": "Charmer - Ivy",
        "datePublished": "2020-04-02T00:00:00-04:00",
        "copyrightHolder": {
            "@type": "Organization",
            "name": "Punknews.org"
        },
        "copyrightYear": "1999-2020",
        "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
        "image": {
          "@type": "ImageObject",
          "url": "https://static.punknews.org/images/covers/large/charmer-ivy.jpg",
          "height": 600,
          "width": 600
        }
      }
    </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/review/17120/charmer-ivy",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 f52279861add869ee928bbbc82226dc1f7c4a683 1585893306',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class="albumreview"><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<li><a href="/?my=stories">My News</a></li>
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li>
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article data-atype="1" data-sid="17120"><div  id="c"><div class="grid-100"><div class="grid-30 review-meta mobile-grid-100"><div><img alt="Charmer - Ivy (Cover Artwork)" src='data:image/svg+xml;charset=utf-8,<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="200" height="200" viewBox="0 0 200 200"><filter id="blur" filterUnits="userSpace OnUse" color-interpolation-filters="sRGB"><feGaussianBlur stdDeviation="10 10" edgeMode="duplicate" /><feComponentTransfer><feFuncA type="discrete" tableValues="1 1" /></feComponentTransfer></filter><image filter="url(%23blur)" xlink:href="data:image/jpeg;base64,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" x="0" y="0" height="100%" width="100%"/></svg>' data-src="https://static.punknews.org/images/covers/charmer-ivy.jpg" data-srcset="https://static.punknews.org/images/covers/charmer-ivy.jpg 1x, https://static.punknews.org/images/covers/large/charmer-ivy.jpg 2x" data-aspectratio="200/200" width="200" height="200"  class="albcover lazyload blur-up" data-sizes="auto"/><div class="editor-label"><i class="fa fa-fw fa-thumbs-o-up"></i> Staff Pick</div></div><h1><a href="/bands/charmer">Charmer</a> </h1><h2>Ivy (2020)</h2><h3><a title="See More About No Sleep Records" href="/labels/nosleep">no sleep records</a></h3><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Charmer%3A+Ivy+%28Review%29&amp;url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17120%2Fcharmer-ivy&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Freview%2F17120%2Fcharmer-ivy" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17120%2Fcharmer-ivy&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Fcovers%2Fcharmer-ivy.jpg&amp;description=Charmer%3A+Ivy+%28Review%29" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17120%2Fcharmer-ivy&amp;name=Charmer%3A+Ivy+%28Review%29&amp;description=Michigan%27s+Charmer+are+another+of+those+Midwest-emo+bands+that+I+wouldn%27t+say+are+part+of+any+revival+or+whatever%2C+as+that+ship+has+sailed.+But+what+I+would+say+is+they%27re+helping+evolve+the+indie-rock-emo+trifecta+which+bands+like+Tiny+Moving+Parts+and+The+Hotelier+have+pushed+over+the+years.+And+w..." class="tbr"><b></b></a></div><label>Reviewer</label> <span itemprop="reviewer"><a rel="author" href="/users/renaldo69#myreviews">RENALDO69</a></span>  <br/><time datetime="2020-04-02">April 2nd 2020</time><div><label>Reviewer Rating</label> <span><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star-o"></i></span></div><label><a href="/login">Login to Rate</a></label></div><div class="grid-70 reviewtext"><p>Michigan's Charmer are another of those Midwest-emo bands that I wouldn't say are part of any revival or whatever, as that ship has sailed. But what I would say is they're helping evolve the indie-rock-emo trifecta which bands like Tiny Moving Parts and The Hotelier have pushed over the years. And what's really brilliant about <i>Ivy</i> is that it doesn't just remarkably follow up their 2018 self-titled debut; it's another big win for No Sleep Records hot on the heels of the last Hot Mulligan record.<br/><br/>Now, I make mention of TMP and they're found a lot on this record, but it's not Charmer aping them or trying to recapture a formula. Think of Modern Baseball (which had a hand in the first album's production) with TMP wrapped in, and you'd get an idea of the melodic, catchy and fast-paced brand of pop-punk at hand. The winding guitars on tracks like "Doom", "Windbreaker" and "December" definitely highlight this comparison and you can even pick up tones of bands like Free Throw, Dowsing, Somos, Pinegrove and The Get Up Kids. In short, there's a lot packed in but Charmer finesses it into a sound of their own. It's something I'm not that surprised at to be honest, not since I first heard "Topanga Lawrence". I don't wanna be that cliched dude that says "they were going places" -- but hey, this record kinda proves me right.<br/><br/>And the way they mix it up, with vocalist David Daignault's clean-cut disposition on the mic, interspersed with little bursts of post-hardcore screamo, it's really a gem to behold. Off the cuff songs like "Slumber" -- a little Tigers Jaw-like jam for those fans -- hook you and I think front-loading the album was a smart idea in this case. The mid-section does flail a bit but the first few tracks are just slobberknocks and a bunch of ear-worms you're not surprised to hear cranked out. One thing I noticed was on "VCR 666" Charmer has potential to go darker and maybe into more of that emo-grunge territory like bands such as Citizen and Sainthood Reps, and hopefully it's something they explore soon. I think they've more than got the talent to pull it off and I can see them going from strength to strength after this because after such brutally honest testaments on life, love and everything in between, the only way is up with technical execution this good.
<br/><br/></div></div><div class="grid-100"><a rel="prev" href="/review/17119"><div class="nocontent grid-50 prev storynav"><h2>Previous Review</h2><span>The ExBats: <i>Kicks, Hits, & Fits</i></span></div></a><a rel="next" href="/review/17121"><div class="nocontent grid-50 next storynav"><h2>Next Review</h2><span>Today is the Day: <i>No Good To Anyone</i></span></div></a></div></div></article><div id="disqus_thread"></div></div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2020 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

