


<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Suck - Frog [EP] | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/review/17279/suck-frog-ep"/>
  <meta name="description" content="Suck excel because they are wonderfully unguarded. Frog  is the German trio&rsquo;s first proper EP and they&rsquo;re already fully formed as a band. Vocalist/synthasist Isabell sets her vocal attack in the sweet spot between singing and screaming, ala Penelope Houston, and every so often she shrieks so har..."/>
  <link rel="amphtml" href="https://www.punknews.org/amp/review/17279/suck-frog-ep"/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Suck - Frog [EP]"/>
  <meta property="twitter:title" content="Suck - Frog [EP]"/>
  <meta property="og:url" content="https://www.punknews.org/review/17279/suck-frog-ep"/>
  <meta property="twitter:url" content="https://www.punknews.org/review/17279/suck-frog-ep"/>
<meta property="og:type" content="album"/>
<meta property="og:description" content="Suck excel because they are wonderfully unguarded. Frog  is the German trio&rsquo;s first proper EP and they&rsquo;re already fully formed as a band. Vocalist/synthasist Isabell sets her vocal attack in the sweet spot between singing and screaming, ala Penelope Houston, and every so often she shrieks so har..."/>
<meta property="twitter:description" content="Suck excel because they are wonderfully unguarded. Frog  is the German trio&rsquo;s first proper EP and they&rsquo;re already fully formed as a band. Vocalist/synthasist Isabell sets her vocal attack in the sweet spot between singing and screaming, ala Penelope Houston, and every so often she shrieks so har..."/>
  <meta property="og:image" content="https://static.punknews.org/images/covers/suck-frog-ep.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/covers/suck-frog-ep.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
        <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "Review",
        "itemReviewed": {
          "@type": "MusicAlbum",
          "byArtist": {
             "@type": "MusicGroup",
            "name": "Suck"
          },
          "name": "Frog [EP]"
        },
        "reviewRating": {
          "@type": "Rating",
          "ratingValue": "8",
          "bestRating": "10",
          "worstRating": "1"

        },
         "author": {
          "@type": "Person",
          "name": "John Gentile"
        },
        "headline": "Suck - Frog [EP]",
        "datePublished": "2020-08-09T00:00:00-04:00",
        "copyrightHolder": {
            "@type": "Organization",
            "name": "Punknews.org"
        },
        "copyrightYear": "1999-2020",
        "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
        "image": {
          "@type": "ImageObject",
          "url": "https://static.punknews.org/images/covers/large/suck-frog-ep.jpg",
          "height": 600,
          "width": 600
        }
      }
    </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/review/17279/suck-frog-ep",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 49233bea5ecdb38bd020891bd5e89141fcd8d330 1597041650',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class="albumreview"><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<li><a href="/?my=stories">My News</a></li>
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li>
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article data-atype="1" data-sid="17279"><div  id="c"><div class="grid-100"><div class="grid-30 review-meta mobile-grid-100"><div><img alt="Suck - Frog [EP] (Cover Artwork)" src='data:image/svg+xml;charset=utf-8,<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="200" height="200" viewBox="0 0 200 200"><filter id="blur" filterUnits="userSpace OnUse" color-interpolation-filters="sRGB"><feGaussianBlur stdDeviation="10 10" edgeMode="duplicate" /><feComponentTransfer><feFuncA type="discrete" tableValues="1 1" /></feComponentTransfer></filter><image filter="url(%23blur)" xlink:href="data:image/jpeg;base64,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" x="0" y="0" height="100%" width="100%"/></svg>' data-src="https://static.punknews.org/images/covers/suck-frog-ep.jpg" data-srcset="https://static.punknews.org/images/covers/suck-frog-ep.jpg 1x, https://static.punknews.org/images/covers/large/suck-frog-ep.jpg 2x" data-aspectratio="200/200" width="200" height="200"  class="albcover lazyload blur-up" data-sizes="auto"/><div class="editor-label"><i class="fa fa-fw fa-thumbs-o-up"></i> Staff Pick</div></div><h1><a href="/bands/suck">Suck</a> </h1><h2>Frog [EP] (2019)</h2><h3>la pochette surprise records ‎</h3><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Suck%3A+Frog+%5BEP%5D+%28Review%29&amp;url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17279%2Fsuck-frog-ep&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Freview%2F17279%2Fsuck-frog-ep" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17279%2Fsuck-frog-ep&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Fcovers%2Fsuck-frog-ep.jpg&amp;description=Suck%3A+Frog+%5BEP%5D+%28Review%29" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Freview%2F17279%2Fsuck-frog-ep&amp;name=Suck%3A+Frog+%5BEP%5D+%28Review%29&amp;description=Suck+excel+because+they+are+wonderfully+unguarded.+Frog++is+the+German+trio%26rsquo%3Bs+first+proper+EP+and+they%26rsquo%3Bre+already+fully+formed+as+a+band.+Vocalist%2Fsynthasist+Isabell+sets+her+vocal+attack+in+the+sweet+spot+between+singing+and+screaming%2C+ala+Penelope+Houston%2C+and+every+so+often+she+shrieks+so+har..." class="tbr"><b></b></a></div><label>Reviewer</label> <span itemprop="reviewer"><a rel="author" href="/users/johngentile#myreviews">John Gentile</a></span>  <br/><time datetime="2020-08-09">August 9th 2020</time><div><label>Reviewer Rating</label> <span><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star-o"></i></span></div><label><a href="/login">Login to Rate</a></label></div><div class="grid-70 reviewtext"><p>Suck excel because they are wonderfully unguarded. <i>Frog</i>  is the German trio’s first proper EP and they’re already fully formed as a band. Vocalist/synthasist Isabell sets her vocal attack in the sweet spot between singing and screaming, ala Penelope Houston, and every so often she shrieks so hard the music red lines. She focuses her at the personal level, detailing getting harassed by boring dudes, or, as on “Roadkill,” she details the fate of jealous backstabbers.<br />
<br />
She’s also really funny. There’s “Mama’s got a backpatch,” which is funny enough just based on the title. But also, as with “Gimme your number,” although she’s just being honest, her exasperation is self-aware and she let’s us joke with her in her exhaustion. And to that point, there’s not artifice here. She’s writing as if she really doesn’t care what you think or even if you side with her or not. But, of course, we do side with her because she let’s us inside her brain and also because she’s not so seriously in that she cant laugh at her own predicament. “I just wanna lose my shit tonight!” she calls out in detachment on “decadent life.” This is the kind of danger and nihilism I like in my punk rock, for sure. <br />
<br />
The music kicks, too. Most of the songs here a re rooted in first or second wave punk charge, with a little hard rock swagger here or there. “Backpatch” starts out as a ripper before it slams down into a Sabbath-esque drone. Nice. Often the band starts off with a hot fire, only to push the track somewhere unusual. “Bulletproof” features Isabell’s synthesizer on the second half where she cranks it like it’s Angus Young’s guitar. Sometimes she uses a Kraftwerk-style vibe and sometimes she spazzes out. The instrument is flexible enough to create a sinister edge or a surprisingly burning solo.<br />
<br />
<i>Frog</i> is the band’s first strike and like many of the greats, this band is already fully functioning and “mature” on their first release. Sometimes, that can be a curse for bands as they can never live up to their initial spark. I’m not fearing that here. There are enough ideas packed into these six tracks that show this band has a lot of places to go, and it looks like it’s going to be a fun ride.
<br/><br/></div></div><div class="grid-100"><a rel="prev" href="/review/17278"><div class="nocontent grid-50 prev storynav"><h2>Previous Review</h2><span>Teen Idols: <i>Stripped Down</i></span></div></a><a rel="next" href="/review/17280"><div class="nocontent grid-50 next storynav"><h2>Next Review</h2><span>Pop Icons: <i>Prelude [EP]</i></span></div></a></div></div></article><div id="disqus_thread"></div></div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2020 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

