

<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released"/>
  <link rel="amphtml" href="https://www.punknews.org/amp/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released"/>
  <meta name="description" content="In 1967, proto-punker Twink of the Pink Fairies recorded a three track instrumental EP as Santa Barbara Machine Head. Ronnie Wood of the Faces and later The Rolling Stones was on that EP, as was Kim Gardner of Big Wheel Recreation and Jon Lord of Deep Purple. Twink re-released the group's recoridn..."/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released"/>
  <meta property="twitter:title" content="Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released"/>
  <meta property="og:url" content="https://www.punknews.org/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released"/>
  <meta property="twitter:url" content="https://www.punknews.org/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released"/>
<meta property="og:description" content="In 1967, proto-punker Twink of the Pink Fairies recorded a three track instrumental EP as Santa Barbara Machine Head. Ronnie Wood of the Faces and later The Rolling Stones was on that EP, as was Kim Gardner of Big Wheel Recreation and Jon Lord of Deep Purple. Twink re-released the group's recoridn..."/>
<meta property="twitter:description" content="In 1967, proto-punker Twink of the Pink Fairies recorded a three track instrumental EP as Santa Barbara Machine Head. Ronnie Wood of the Faces and later The Rolling Stones was on that EP, as was Kim Gardner of Big Wheel Recreation and Jon Lord of Deep Purple. Twink re-released the group's recoridn..."/>
  <meta property="og:image" content="https://static.punknews.org/images/frontpage/fp-1561657681.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/frontpage/fp-1561657681.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
  <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released",
      "datePublished": "2020-09-30T15:00:01-04:00",
        "dateModified": "2020-09-30T15:45:01-04:00",
      "author": {
          "@type": "Person",
          "name": "John Gentile"
        },
      "copyrightHolder": {
          "@type": "Organization",
          "name": "Punknews.org"
      },
      "copyrightYear": "1999-2020",
      "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
      "image": {
        "@type": "ImageObject",
        "url": "/images/frontpage/fp-1561657681.jpg",
        "height": 600,
          "width": 400
      }
    }
  </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 7e3c8952db5c5f8e06a0dc6a2ef2aa6145ac7226 1601495102',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class=""><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<li><a href="/?my=stories">My News</a></li>
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li>
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article class="grid-100" data-atype="0" data-sid="73401"><div class="article-box grid-parent stickem-container">
<div class="apage mobile-grid-100 grid-parent grid-100"><h1><a href="/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released">Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released</a></h1></div><div class="grid-65 mobile-push-100"><section data-src="#hometext" class="apage grid-parent hometext"><a href="/article/73401/twink-ronnie-wood-jon-lord-kim-gardner-ep-re-released"><img alt="Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released" src='data:image/svg+xml;charset=utf-8,<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="600" height="400" viewBox="0 0 600 400"><filter id="blur" filterUnits="userSpace OnUse" color-interpolation-filters="sRGB"><feGaussianBlur stdDeviation="10 10" edgeMode="duplicate" /><feComponentTransfer><feFuncA type="discrete" tableValues="1 1" /></feComponentTransfer></filter><image filter="url(%23blur)" xlink:href="data:image/jpeg;base64,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" x="0" y="0" height="100%" width="100%"/></svg>' data-src="https://static.punknews.org/images/frontpage/fp-1561657681.jpg" data-srcset="https://static.punknews.org/images/frontpage/fp-1561657681.jpg 1x, " data-aspectratio="600/400" width="600" height="400" class="articleimage lazyload blur-up" data-sizes="auto"/></a><div class="grid-100 tablet-grid-0 mobile-grid-100 ops">by <a rel="author" href="/users/johngentile"><i class="fa fa-user-plus"></i>John Gentile</a> <time datetime="2020-09-30 15:00:01">45 minutes ago</time></div><p> In 1967, proto-punker <a>Twink</a> of the <a>Pink Fairies</a> recorded a three track instrumental EP as <a>Santa Barbara Machine Head</a>. Ronnie Wood of the <a>Faces</a> and later <a href="/bands/therollingstones">The Rolling Stones</a> was on that EP, as was Kim Gardner of <a href="/labels/bigwheelrec">Big Wheel Recreation</a> and Jon Lord of <a>Deep Purple</a>. Twink re-released the group's recoridngs today. You can hear that below.</p></section><section class="bodytext " data-src="#bodytext"><iframe style="border: 0; width: 100%; height: auto;" src="//bandcamp.com/EmbeddedPlayer/album=3604231247/size=large/bgcol=fafafa/linkcol=486591/tracklist=false/artwork=small/transparent=true/" seamless><a href="https://thinkpink50th.bandcamp.com/album/santa-barbara-machine-head-1967">Santa Barbara Machine Head (1967) by Santa Barbara Machine Head</a></iframe></section></div><div id="stickframe" class="grid-35 mobile-grid-100 mobile-pull-100"><div class="stickem"><div id="div-gpt-ad-1440799965676-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440799965676-0")})</script></div><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Twink+%2F+Ronnie+Wood+%2F+Jon+Lord+%2F+Kim+Gardner+EP+re-released&amp;url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73401%2Ftwink-ronnie-wood-jon-lord-kim-gardner-ep-re-released&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73401%2Ftwink-ronnie-wood-jon-lord-kim-gardner-ep-re-released" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73401%2Ftwink-ronnie-wood-jon-lord-kim-gardner-ep-re-released&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Ffrontpage%2Ffp-1561657681.jpg&amp;description=Twink+%2F+Ronnie+Wood+%2F+Jon+Lord+%2F+Kim+Gardner+EP+re-released" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73401%2Ftwink-ronnie-wood-jon-lord-kim-gardner-ep-re-released&amp;name=Twink+%2F+Ronnie+Wood+%2F+Jon+Lord+%2F+Kim+Gardner+EP+re-released&amp;description=In+1967%2C+proto-punker+Twink+of+the+Pink+Fairies+recorded+a+three+track+instrumental+EP+as+Santa+Barbara+Machine+Head.+Ronnie+Wood+of+the+Faces+and+later+The+Rolling+Stones+was+on+that+EP%2C+as+was+Kim+Gardner+of+Big+Wheel+Recreation+and+Jon+Lord+of+Deep+Purple.+Twink+re-released+the+group%27s+recoridn..." class="tbr"><b></b></a></div><div id="div-gpt-ad-1442923783286-0" 120x240.html><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1442923783286-0")})</script></div></div></div>
</div>
</article><a rel="prev" href="/article/73400"><div class="nocontent grid-50 mobile-grid-100 prev storynav"><h2>Previous Story</h2><span rel="prev"> Pearl Harbour / East Bay Ray album re-released</span></div></a><a href="/"><div class="hide-on-mobile grid-50 storynav next"><h2><i class="fa fa-home"></i></h2>Go to the home page</div></a><div class="relates"><ul><li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1561657681.jpg);background-size: cover"><a href="/article/73401"><h1>Twink / Ronnie Wood / Jon Lord / Kim Gardner EP re-released</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1552575950.jpg);background-size: cover"><a href="/article/69369"><h1>Rolling Stones to release new greatest hits album called 'Honk'</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1547560513.jpg);background-size: cover"><a href="/article/68938"><h1>Melvins cover Rolling Stones' "Sway"</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1530233609.jpg);background-size: cover"><a href="/article/67450"><h1>Listen to the Summer Soiree Radio Special!</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/therollingstones-1342128201.jpg);background-size: cover"><a href="/article/62522"><h1>The Rolling Stones: "Ride 'em On Down"</h1></a></li>
</ul></div><div id="disqus_thread"></div>
</div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2020 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

