

<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/article/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp"/>
  <link rel="amphtml" href="https://www.punknews.org/amp/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp"/>
  <meta name="description" content="Liquid Death is a company that sells canned water. They recently commissioned an album called Greatest Hates Volume 2. The album features contributions from members of Lawrence Arms, Rise Against, Alkaline Trio, Bombpops, Anti-Flag, JER, Death by Stereo, Pinkshift, and more.  The hook is that all ..."/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP"/>
  <meta property="twitter:title" content="Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP"/>
  <meta property="og:url" content="https://www.punknews.org/article/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp"/>
  <meta property="twitter:url" content="https://www.punknews.org/article/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp"/>
<meta property="og:description" content="Liquid Death is a company that sells canned water. They recently commissioned an album called Greatest Hates Volume 2. The album features contributions from members of Lawrence Arms, Rise Against, Alkaline Trio, Bombpops, Anti-Flag, JER, Death by Stereo, Pinkshift, and more.  The hook is that all ..."/>
<meta property="twitter:description" content="Liquid Death is a company that sells canned water. They recently commissioned an album called Greatest Hates Volume 2. The album features contributions from members of Lawrence Arms, Rise Against, Alkaline Trio, Bombpops, Anti-Flag, JER, Death by Stereo, Pinkshift, and more.  The hook is that all ..."/>
  <meta property="og:image" content="https://static.punknews.org/images/frontpage/fp-1605726029.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/frontpage/fp-1605726029.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
  <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP",
      "datePublished": "2020-11-18T14:30:01-05:00",
        "dateModified": "2020-11-18T20:51:36-05:00",
      "author": {
          "@type": "Person",
          "name": "John Gentile"
        },
      "copyrightHolder": {
          "@type": "Organization",
          "name": "Punknews.org"
      },
      "copyrightYear": "1999-2020",
      "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
      "image": {
        "@type": "ImageObject",
        "url": "/images/frontpage/large/fp-1605726029.jpg",
        "height": 1080,
          "width": 720
      }
    }
  </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/article/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 6a1cf11ec906795d7c4197a1466fd88197c78872 1605750698',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class=""><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<li><a href="/?my=stories">My News</a></li>
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li>
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article class="grid-100" data-atype="0" data-sid="73653"><div class="article-box grid-parent stickem-container">
<div class="topstory grid-100"><h1><a href="/article/73653/lawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp">Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP</a></h1><img alt="Lawrence Arms, Rise Against, Alk3, Anti-Flag on Liquid Death LP" src="https://static.punknews.org/images/frontpage/large/fp-1605726029.jpg" data-src="https://static.punknews.org/images/frontpage/large/fp-1605726029.jpg" data-srcset="https://static.punknews.org/images/frontpage/large/fp-1605726029.jpg 1x, " data-aspectratio="1080/720" width="1080" height="720" class="firstimage"  />
</div><div class="apage grid-100 mobile-grid-100" style="padding: 0"><div class="grid-100 tablet-grid-0 mobile-grid-100 ops">Contributed by <i class="fa fa-user"></i><a href="/users/desertburst92">desertburst92</a>, Posted by <a rel="author" href="/users/johngentile"><i class="fa fa-user-plus"></i>John Gentile</a> <time datetime="2020-11-18 14:30:01">6 hours ago</time></div></div><div class="grid-parent grid-100"></div><div class="grid-65"><section data-src="#hometext" class="grid-parent hometext"><p> Liquid Death is a company that sells canned water. They recently commissioned an album called <i>Greatest Hates Volume 2</i>. The album features contributions from members of <a href="/bands/thelawrencearms">Lawrence Arms</a>, <a href="/bands/riseagainst">Rise Against</a>, <a href="/bands/alkalinetrio">Alkaline Trio</a>, <a href="/bands/thebombpops">Bombpops</a>, <a href="/bands/antiflag">Anti-Flag</a>, JER, <a href="/bands/deathbystereo">Death by Stereo</a>, <a href="/bands/pinkshift">Pinkshift</a>, and more. </p><p>The hook is that all of the songs have their lyrics derived from negative comments left on the brand's social media pages. It's out now digitally and a physical version is out in January.</p></section><section class="bodytext " data-src="#bodytext"><iframe width="640" height="360" src="//www.youtube.com/embed/xzwjYmYF9mg?showinfo=0&amp;color=white&amp;feature=oembed&amp;enablejsapi=1&amp;autohide=1&amp;rel=0&amp;iv_load_policy=3&amp;autoplay=0" allowfullscreen></iframe></section></div><div id="stickframe" class="grid-35 mobile-grid-100 mobile-pull-100"><div class="stickem"><div id="div-gpt-ad-1440799965676-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440799965676-0")})</script></div><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Lawrence+Arms%2C+Rise+Against%2C+Alk3%2C+Anti-Flag+on+Liquid+Death+LP&amp;url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73653%2Flawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73653%2Flawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73653%2Flawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Ffrontpage%2Ffp-1605726029.jpg&amp;description=Lawrence+Arms%2C+Rise+Against%2C+Alk3%2C+Anti-Flag+on+Liquid+Death+LP" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F73653%2Flawrence-arms-rise-against-alk3-anti-flag-on-liquid-death-lp&amp;name=Lawrence+Arms%2C+Rise+Against%2C+Alk3%2C+Anti-Flag+on+Liquid+Death+LP&amp;description=Liquid+Death+is+a+company+that+sells+canned+water.+They+recently+commissioned+an+album+called+Greatest+Hates+Volume+2.+The+album+features+contributions+from+members+of+Lawrence+Arms%2C+Rise+Against%2C+Alkaline+Trio%2C+Bombpops%2C+Anti-Flag%2C+JER%2C+Death+by+Stereo%2C+Pinkshift%2C+and+more.+%0D+The+hook+is+that+all+..." class="tbr"><b></b></a></div><div id="div-gpt-ad-1442923783286-0" 120x240.html><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1442923783286-0")})</script></div></div></div>
</div>
</article><a rel="prev" href="/article/73652"><div class="nocontent grid-50 mobile-grid-100 prev storynav"><h2>Previous Story</h2><span rel="prev"><i class="fa fa-beer"></i>Festivals & Events:  The Bouncing Souls to stream Home For The Holiday</span></div></a><a rel="next" href="/article/73654"><div class="grid-50 mobile-grid-100 next storynav"><h2>Next Story</h2><i class="fa fa-beer"></i>Festivals & Events:  Shame announce new album, release music video</div></a><div class="relates"><ul><li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1605726029.jpg);background-size: cover"><a href="/article/73653"><h1>Lawrence Arms, Rise Against, Alk3, Bombpops, Anti-Flag on Liquid Death album</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1605535440.jpg);background-size: cover"><a href="/article/73640"><h1>The Lawrence Arms announce War On X-Mas livestream</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/pinkshift-1603465790.jpg);background-size: cover"><a href="/article/73522"><h1>Pinkshift release digital single</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1602707537.jpg);background-size: cover"><a href="/article/73477"><h1>Dan Vapid, Jen Pop and Poli Van Dam to play T1 Fest</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/thelawrencearms-1600964755.jpg);background-size: cover"><a href="/article/73371"><h1>The Lawrence Arms release "Ghostwriter" video</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1600869938.jpg);background-size: cover"><a href="/article/73369"><h1>2000trees announce 2021 line-up</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/deadending-1391185156.jpg);background-size: cover"><a href="/article/73257"><h1>Dead Ending to release new 7-inch</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/thedwarves-1534438744.jpg);background-size: cover"><a href="/article/73221"><h1>Blag Dahlia of the Dwarves recording with Jen of Bombpops</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/thelawrencearms-1389717185.jpg);background-size: cover"><a href="/article/73171"><h1>The Lawrence Arms release "Quiet Storm" video</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1597156666.jpg);background-size: cover"><a href="/article/73162"><h1>Tim McIlrath, Lou Koller, Mike Herrera, Darren Pfeiffer, Moby cover Black Flag</h1></a></li>
</ul></div><div id="disqus_thread"></div>
</div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2020 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

