

<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Members of Comeback Kid, Junior Battles featured on "Bow Your Eyes, Close Your Head" podcast | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast"/>
  <link rel="amphtml" href="https://www.punknews.org/amp/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast"/>
  <meta name="description" content="Musician and comedian Gabe Koury recently launched Bow Your Eyes, Close Your Head, a podcast that talks to personalities in punk, comedy, and other alternative subcultures who were raised in (and in many cases grew apart from) strict religious backgrounds. Recent episodes have spoken to Joel Dickau..."/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Members of Comeback Kid, Junior Battles featured on &quot;Bow Your Eyes, Close Your Head&quot; podcast"/>
  <meta property="twitter:title" content="Members of Comeback Kid, Junior Battles featured on &quot;Bow Your Eyes, Close Your Head&quot; podcast"/>
  <meta property="og:url" content="https://www.punknews.org/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast"/>
  <meta property="twitter:url" content="https://www.punknews.org/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast"/>
<meta property="og:description" content="Musician and comedian Gabe Koury recently launched Bow Your Eyes, Close Your Head, a podcast that talks to personalities in punk, comedy, and other alternative subcultures who were raised in (and in many cases grew apart from) strict religious backgrounds. Recent episodes have spoken to Joel Dickau..."/>
<meta property="twitter:description" content="Musician and comedian Gabe Koury recently launched Bow Your Eyes, Close Your Head, a podcast that talks to personalities in punk, comedy, and other alternative subcultures who were raised in (and in many cases grew apart from) strict religious backgrounds. Recent episodes have spoken to Joel Dickau..."/>
  <meta property="og:image" content="https://static.punknews.org/images/frontpage/fp-1620957342.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/frontpage/fp-1620957342.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
  <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "Members of Comeback Kid, Junior Battles featured on Bow Your Eyes, Close Your Head podcast",
      "datePublished": "2021-05-14T09:30:01-04:00",
        "dateModified": "2021-05-15T06:08:23-04:00",
      "author": {
          "@type": "Person",
          "name": "Adam White"
        },
      "copyrightHolder": {
          "@type": "Organization",
          "name": "Punknews.org"
      },
      "copyrightYear": "1999-2021",
      "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
      "image": {
        "@type": "ImageObject",
        "url": "https://static.punknews.org/images/frontpage/fp-1620957342.jpg",
        "height": 600,
          "width": 400
      }
    }
  </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 c1bd51fbb6fc12adb1e1027480bf226d50ab4934 1621074320',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class=""><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<!-- li><a href="/?my=stories">My News</a></li -->
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<!--<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li> -->
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article class="grid-100" data-atype="0" data-sid="74681"><div class="article-box grid-parent stickem-container">
<div class="apage mobile-grid-100 grid-parent grid-100"><h1><a href="/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast">Members of Comeback Kid, Junior Battles featured on &ldquo;Bow Your Eyes, Close Your Head&rdquo; podcast</a></h1></div><div class="grid-65 mobile-push-100"><section data-src="#hometext" class="apage grid-parent hometext"><a href="/article/74681/members-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast"><img alt="Members of Comeback Kid, Junior Battles featured on &quot;Bow Your Eyes, Close Your Head&quot; podcast" src='data:image/svg+xml;charset=utf-8,<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="600" height="400" viewBox="0 0 600 400"><filter id="blur" filterUnits="userSpace OnUse" color-interpolation-filters="sRGB"><feGaussianBlur stdDeviation="10 10" edgeMode="duplicate" /><feComponentTransfer><feFuncA type="discrete" tableValues="1 1" /></feComponentTransfer></filter><image filter="url(%23blur)" xlink:href="data:image/jpeg;base64,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" x="0" y="0" height="100%" width="100%"/></svg>' data-src="https://static.punknews.org/images/frontpage/fp-1620957342.jpg" data-srcset="https://static.punknews.org/images/frontpage/fp-1620957342.jpg 1x, " data-aspectratio="600/400" width="600" height="400" class="articleimage lazyload blur-up" data-sizes="auto"/></a><div class="grid-100 tablet-grid-0 mobile-grid-100 ops">by <a rel="author" href="/users/adam"><i class="fa fa-user-plus"></i>Adam White</a> <a title="Find out more about Paper and Plastick" href="/labels/paperandplastick"><i class="fa fa-tags"></i> Paper and Plastick</a> <time datetime="2021-05-14 09:30:01">21 hours ago</time></div><p> Musician and comedian Gabe Koury recently launched <a href="https://anchor.fm/byecyh">Bow Your Eyes, Close Your Head</a>, a podcast that talks to personalities in punk, comedy, and other alternative subcultures who were raised in (and in many cases grew apart from) strict religious backgrounds. Recent episodes have spoken to Joel Dickau of <a href="/bands/juniorbattles">Junior Battles</a>, tour manager Tanner Brooke, comedian John Michael Bond, Matty Cusick of <a>Yeah Bud!</a>, sketch comic Guled Abdi (CBC's Tallboyz II Men), Andrew "Goose" Neufeld <a href="/bands/comebackkid">Comeback Kid</a>, and Toronto music personality Tim McCready. The show's billed as "a podcast about creative heathens talking about youth groups and Tooth &amp; Nail bands&hellip; grab your devotion notes and Squad Five-0 cd's and let's go!"</p></section><section class="bodytext " data-src="#bodytext"><p> Koury currently works as a music publicist in Toronto, notably booking the infamous <a href="https://bovinesexclub.com">Bovine Sex Club</a>. He played in the Montreal punk group <a href="/bands/wnslow">W!NSLOW</a> in the early 2000s. In a statement, he elaborated on his own background, commenting: </p><blockquote><p>I grew up in fairly big Italian Pentecostal Churches in Montreal, QC from birth to the ages of 22/23 years old. I found some solace in it but was also, without fail, confused and conflicted due my creative soul trying to seek truth and some relatable sustenance. This pod's goal is to explore more faiths, religions, and fellow artists' stories of navigating through life and trying to be a good person.</p></blockquote><p> Here's a sample of what the chat with Comeback Kid's Andrew Newfeld has in store:</p><blockquote><p>Andrew is a one of the forefathers of modern Canadian punk and hardcore. Frontmen of one of the most notoriously fast, heavy bands Comeback Kid, Andrew talks about his upbringing in a non-denominational church in Winnipeg, MB, touring both secular and Christian circuits, fear (the feeling not the band), SNFU, meeting Mike from MXPX, Mennonites, musical family and Russel Crowe movies where he's a fictional, conservative father sending his kid to conversion camp.</p></blockquote><p>You can check the show out now at <a href="https://anchor.fm/byecyh">Spotify</a>.</p></section></div><div id="stickframe" class="grid-35 mobile-grid-100 mobile-pull-100"><div class="stickem"><div id="div-gpt-ad-1440799965676-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440799965676-0")})</script></div><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Members+of+Comeback+Kid%2C+Junior+Battles+featured+on+%22Bow+Your+Eyes%2C+Close+Your+Head%22+podcast&amp;url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F74681%2Fmembers-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Farticle%2F74681%2Fmembers-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F74681%2Fmembers-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Ffrontpage%2Ffp-1620957342.jpg&amp;description=Members+of+Comeback+Kid%2C+Junior+Battles+featured+on+%22Bow+Your+Eyes%2C+Close+Your+Head%22+podcast" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F74681%2Fmembers-of-comeback-kid-junior-battles-featured-on-bow-your-eyes-close-your-head-podcast&amp;name=Members+of+Comeback+Kid%2C+Junior+Battles+featured+on+%22Bow+Your+Eyes%2C+Close+Your+Head%22+podcast&amp;description=Musician+and+comedian+Gabe+Koury+recently+launched+Bow+Your+Eyes%2C+Close+Your+Head%2C+a+podcast+that+talks+to+personalities+in+punk%2C+comedy%2C+and+other+alternative+subcultures+who+were+raised+in+%28and+in+many+cases+grew+apart+from%29+strict+religious+backgrounds.+Recent+episodes+have+spoken+to+Joel+Dickau..." class="tbr"><b></b></a></div><div id="div-gpt-ad-1442923783286-0" 120x240.html><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1442923783286-0")})</script></div></div></div>
</div>
</article><a rel="prev" href="/article/74680"><div class="nocontent grid-50 mobile-grid-100 prev storynav"><h2>Previous Story</h2><span rel="prev">In Memoriam:  Jack Terricloth of World/Inferno has passed away</span></div></a><a rel="next" href="/article/74682"><div class="grid-50 mobile-grid-100 next storynav"><h2>Next Story</h2>In Memoriam:  Lost In Society release "Say Anything"</div></a><div class="relates"><ul><li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/fp-1620957342.jpg);background-size: cover"><a href="/article/74681"><h1>Members of Comeback Kid, Junior Battles featured on "Bow Your Eyes, Close Your Head" podcast</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/nofx-1613491635.jpg);background-size: cover"><a href="/article/74245"><h1>Slam Dunk Festival announce 2021 line-up</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1615205988.jpg);background-size: cover"><a href="/article/74223"><h1>Furnace Fest announce 2021 line-up</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/comebackkid-1535378170.jpg);background-size: cover"><a href="/article/73233"><h1>Comeback Kid release SNFU cover</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1588345023.jpg);background-size: cover"><a href="/article/72555"><h1>Fest adds Gorilla Biscuits, Sheer Mag, World/Inferno, Kepi, Mikey Erg, many more</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1582902850.jpg);background-size: cover"><a href="/article/72035"><h1>Punkredible announce line-up</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/comebackkid-1535378170.jpg);background-size: cover"><a href="/article/72002"><h1>Comeback Kid announce tour dates in Asia</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1576761154.jpg);background-size: cover"><a href="/article/71715"><h1>Furnace Fest announce more bands</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1574707036.jpg);background-size: cover"><a href="/article/71338"><h1>Circle Jerks to play 'Punk in Drublic' Europe and maybe more dates</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/comebackkid-1535378170.jpg);background-size: cover"><a href="/article/71142"><h1>Comeback Kid (AU)</h1></a></li>
</ul></div><div id="disqus_thread"></div>
</div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2021 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//code.jquery.com/jquery-3.6.0.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

