

<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8"/>
  <title>Tim Kasher of Cursive announces solo album, releases video | Punknews.org</title>
  <meta name="theme-color" content="#486591">
  <meta name="author" content="Punknews.org"/>
  <meta name="generator" content="Punknews.org/ForkedNuke 5.0"/>
  <meta name="mobile-web-app-capable" content="yes"/>
  <link rel="icon" sizes="196x196" href="https://static.punknews.org/images/favicons/chrome-touch-icon.png"/>
  <meta name="apple-mobile-web-app-capable" content="yes"/>
  <meta name="apple-mobile-web-app-status-bar-style" content="black"/>
  <meta name="apple-mobile-web-app-title" content="Punknews.org"/>
  <link rel="manifest" href="/manifest.json"/>
  <link rel="mask-icon" href="/images/icons/pnpinned.svg" color="#486591"/>
  <meta name="msapplication-TileImage" content="/images/touch/ms-touch-icon.png"/>
  <meta name="msapplication-TileColor" content="#486591"/>
  <link rel="canonical" href="https://www.punknews.org/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video"/>
  <link rel="amphtml" href="https://www.punknews.org/amp/76713/tim-kasher-of-cursive-announces-solo-album-releases-video"/>
  <meta name="description" content="Tim Kasher of Cursive and Good Life has announced that he will be releasing a new solo album. The album is called Middling Age and will be out April 15 via 15 Passenger Records. Jayson Gerycz of Cloud Nothings played percussion on the album. He has released a video for the first single &quot;I Don't Th..."/>
  <meta property="fb:app_id" content="48661901078" />
  <meta property="fb:pages" content="23173142808" />
  <meta name="twitter:site" content="@punknews" />
  <meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1" />
  <meta property="og:title" content="Tim Kasher of Cursive announces solo album, releases video"/>
  <meta property="twitter:title" content="Tim Kasher of Cursive announces solo album, releases video"/>
  <meta property="og:url" content="https://www.punknews.org/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video"/>
  <meta property="twitter:url" content="https://www.punknews.org/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video"/>
<meta property="og:description" content="Tim Kasher of Cursive and Good Life has announced that he will be releasing a new solo album. The album is called Middling Age and will be out April 15 via 15 Passenger Records. Jayson Gerycz of Cloud Nothings played percussion on the album. He has released a video for the first single &quot;I Don't Th..."/>
<meta property="twitter:description" content="Tim Kasher of Cursive and Good Life has announced that he will be releasing a new solo album. The album is called Middling Age and will be out April 15 via 15 Passenger Records. Jayson Gerycz of Cloud Nothings played percussion on the album. He has released a video for the first single &quot;I Don't Th..."/>
  <meta property="og:image" content="https://static.punknews.org/images/frontpage/fp-1645541472.jpg" />
  <meta name="twitter:card" content="summary" />
  <meta property="twitter:image" content="https://static.punknews.org/images/frontpage/fp-1645541472.jpg" />
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org News" href="https://static.punknews.org/feeds/punknews.rdf"/>
  <link rel="alternate" type="application/rss+xml"
  title="RSS Feed: Punknews.org Reviews" href="https://static.punknews.org/feeds/punknews-reviews.rdf"/>
  <link rel="shortcut icon" href="https://static.punknews.org/images/favicons/favicon.ico"/>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5649346055395053",enable_page_level_ads:!0})</script>
  <link rel="dns-prefetch" href="//static.punknews.org"><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"><link rel="dns-prefetch" href="//ajax.googleapis.com"><link rel="preconnect" href="//static.punknews.org" crossorigin>
  <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "Tim Kasher of Cursive announces solo album, releases video",
      "datePublished": "2022-02-22T10:00:01-05:00",
        "dateModified": "2022-02-23T03:43:19-05:00",
      "author": {
          "@type": "Person",
          "name": "Em Moore"
        },
      "copyrightHolder": {
          "@type": "Organization",
          "name": "Punknews.org"
      },
      "copyrightYear": "1999-2022",
      "publisher": {
          "@type": "Organization",
          "name": "Punknews.org",
          "logo": {
            "@type": "ImageObject",
            "url": "https://static.punknews.org/images/logo/punknews-logo-ld.png",
            "width": 337,
            "height": 60
          }
        },
      "image": {
        "@type": "ImageObject",
        "url": "https://static.punknews.org/images/frontpage/fp-1645541472.jpg",
        "height": 600,
          "width": 400
      }
    }
  </script>
  <link href="https://static.punknews.org/styles/screen.min.css" rel="stylesheet" type="text/css" media="screen"/>
  <link href="https://static.punknews.org/styles/print.min.css" rel="stylesheet" type="text/css" media="print"/>
  <link href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css' rel='stylesheet' type='text/css' media='screen'/><script>  var disqus_shortname="punknews",disqus_url="https://www.punknews.org/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video",disqus_config=function(){this.page.remote_auth_s3='eyJpZCI6ZmFsc2UsInVzZXJuYW1lIjpmYWxzZSwiZW1haWwiOmZhbHNlLCJhdmF0YXIiOiJodHRwOlwvXC93d3cuZ3JhdmF0YXIuY29tXC9hdmF0YXJcL2Q0MWQ4Y2Q5OGYwMGIyMDRlOTgwMDk5OGVjZjg0MjdlP3M9MjAwJmFtcDtkPW1tJmFtcDtyPSJ9 9894252d7fd944eba10be712ebb85cb5f791fd8d 1645606560',this.page.api_key="OhbdS21AtCxtmDabLXgjIlH9UvMs6WmZPK2GfdyNCvLugR55wHcdalnwWTAc9J3e",this.callbacks.onReady.push(function(){$(document.body).trigger("sticky_kit:recalc")})};this.sso={name:"Punknews.org",button:"https://static.punknews.org/images/icons/large/punknews-logo-32px.png",icon:"https://static.punknews.org/images/favicons/apple-touch-icon-114x114.png",url:"https://www.punknews.org/login",logout:"https://www.punknews.org/logout",width:"800",height:"400"};</script>
</head>
<body class=""><div id="site-wrapper"><div id="site-canvas">
<script>!function(e,a,t,n,g,c,o){e.GoogleAnalyticsObject=g,e.ga=e.ga||function(){(e.ga.q=e.ga.q||[]).push(arguments)},e.ga.l=1*new Date,c=a.createElement(t),o=a.getElementsByTagName(t)[0],c.async=1,c.src="//www.google-analytics.com/analytics.js",o.parentNode.insertBefore(c,o)}(window,document,"script",0,"ga"),ga("create","UA-48439990-1","auto"),ga("send","pageview")</script><div class="blue"><div id="div-gpt-ad-1440508639051-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-0")})</script></div></div><div id="sticky">
<header class="grid-parent">
<div class="mobile-grid-10 hide-on-desktop hide-on-tablet">
<a class="toggle-nav" href="#nav">
<i class="fa fa-bars"></i></a></div>
<div class="grid-50 mobile-grid-80 tablet-grid-80 logo">
<h1>
<a href="/"><img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="190" height="34"/></a></h1>
</div>
<div class="grid-50 mobile-grid-10 tablet-grid-20" >
<form id="search" action="/search">
    <input type="search" name="q"/>
</form>
</div>
</header>
<div class="clearfix"></div>
 <nav class="clearfix" id="subtitle">
   <ul id="menu" class="clearfix">
<li class="hide-on-desktop hide-on-tablet"><a class="toggle-nav" href="#nav"><i class="fa fa-times"></i></a></li>
<li><a title="Return to Home Page" id="phomenav" href="/">Home</a></li>
<!-- li><a href="/?my=stories">My News</a></li -->
<li><a title="Check out some new music reviews" id="previewsnav" href="/reviews">Reviews</a></li>
<li><a title="Submit a story or tip" id="psubmitnav" href="/submit">Tips?</a></li>
<li class="hide-on-tablet"><a title="Browse through thousands of band profiles"  id="pbandsnav"  href="/bands">Bands</a></li>
<!-- <li><a href="#">Sections <i class="fa fa-caret-down"></i> </a> -->
<li class="hide-on-tablet"><a title="New Interviews" id="pinterviewsnav" href="/interviews">Interviews</a></li>
<li class="hide-on-tablet"><a title="Best New Music" id="bnewmusic" href="/recommendations">Best New Music</a></li>
<li class="hide-on-tablet"><a title="Podcasts" id="podcast" href="/podcast">Podcasts</a></li>
<li class="hide-on-tablet"><a title="Tours" id="ptoursnav" href="/tours">Tours</a></li>
<!--<li><a title="Browse upcoming releases and add reminders." id="preleasesnav"  href="/releases">New Releases</a></li> -->
<li><a title="Your Account" id="user" href="/login"><i class="fa fa-user"></i> Login</a></li></ul>
</nav>
</div>
<div id="mainframe" class="grid-container grid-parent"><article class="grid-100" data-atype="0" data-sid="76713"><div class="article-box grid-parent stickem-container">
<div class="apage mobile-grid-100 grid-parent grid-100"><h1><a href="/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video">Tim Kasher of Cursive announces solo album, releases video</a></h1></div><div class="grid-65 mobile-push-100"><section data-src="#hometext" class="apage grid-parent hometext"><a href="/article/76713/tim-kasher-of-cursive-announces-solo-album-releases-video"><img alt="Tim Kasher of Cursive announces solo album, releases video" src='data:image/svg+xml;charset=utf-8,<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="300" height="200" viewBox="0 0 300 200"><filter id="blur" filterUnits="userSpace OnUse" color-interpolation-filters="sRGB"><feGaussianBlur stdDeviation="10 10" edgeMode="duplicate" /><feComponentTransfer><feFuncA type="discrete" tableValues="1 1" /></feComponentTransfer></filter><image filter="url(%23blur)" xlink:href="data:image/jpeg;base64,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" x="0" y="0" height="100%" width="100%"/></svg>' data-src="https://static.punknews.org/images/frontpage/fp-1645541472.jpg" data-srcset="https://static.punknews.org/images/frontpage/fp-1645541472.jpg 1x, " data-aspectratio="600/400" width="600" height="400" class="articleimage lazyload blur-up" data-sizes="auto"/></a><div class="grid-100 tablet-grid-0 mobile-grid-100 ops">by <a rel="author" href="/users/emmoore"><i class="fa fa-user-plus"></i>Em Moore</a> <time datetime="2022-02-22 10:00:01">18 hours ago</time></div><p> <a href="/bands/timkasher">Tim Kasher</a> of <a href="/bands/cursive">Cursive</a> and <a href="/bands/thegoodlife">Good Life</a> has announced that he will be releasing a new solo album. The album is called <i>Middling Age</i> and will be out April 15 via 15 Passenger Records. Jayson Gerycz of <a href="/bands/cloudnothings">Cloud Nothings</a> played percussion on the album. He has released a video for the first single "I Don't Think About You". The song features guest vocals from Megan Siebe of <a href="/bands/cursive">Cursive</a>. Tim Kasher released his solo album <a href="/review/14949/tim-kasher-no-resolution"> <i>No Resolution</i> </a> in 2017. Check out the video and tracklist below.</p></section><section class="bodytext " data-src="#bodytext"><iframe width="880" height="495" src="//www.youtube.com/embed/Wf-I4BnJn_0?showinfo=0&amp;color=white&amp;feature=oembed&amp;enablejsapi=1&amp;autohide=1&amp;rel=0&amp;iv_load_policy=3&amp;autoplay=0" title="YouTube video player" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe><p> <i>Middling Age</i> Tracklist</p><p> 1. Middling Age Anxiety Prolouge (feat. 'Long Days' by Natalie Tetro)</p><p> 2. I Don’t Think About You</p><p> 3. What Are We Doing</p><p> 4.The John Jouberts</p><p> 5. 100 Ways To Paint A Bowl Of Limes</p><p> 6. On My Knees</p><p> 7. You Don’t Gotta Beat Yourself Up About It</p><p> 8. Life Coach</p><p> 9. Whisper Your Death Wish</p><p> 10. Up And Cut Me Loose</p><p> 11. Forever Of The Living Dead (feat. Laura Jane Grace, Jeff Rosenstock)</p></section></div><div id="stickframe" class="grid-35 mobile-grid-100 mobile-pull-100"><div class="stickem"><div id="div-gpt-ad-1440799965676-0"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440799965676-0")})</script></div><div class="social-share"><a href="#disqus_thread" class="com"><b></b></a><a href="https://twitter.com/intent/tweet/?text=Tim+Kasher+of+Cursive+announces+solo+album%2C+releases+video&amp;url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F76713%2Ftim-kasher-of-cursive-announces-solo-album-releases-video&amp;via=punknews" class="twt"><b></b></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.punknews.org%2Farticle%2F76713%2Ftim-kasher-of-cursive-announces-solo-album-releases-video" class="fbk"><b></b></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F76713%2Ftim-kasher-of-cursive-announces-solo-album-releases-video&amp;media=https%3A%2F%2Fstatic.punknews.org%2Fimages%2Ffrontpage%2Ffp-1645541472.jpg&amp;description=Tim+Kasher+of+Cursive+announces+solo+album%2C+releases+video" class="pin"><b></b></a><a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.punknews.org%2Farticle%2F76713%2Ftim-kasher-of-cursive-announces-solo-album-releases-video&amp;name=Tim+Kasher+of+Cursive+announces+solo+album%2C+releases+video&amp;description=Tim+Kasher+of+Cursive+and+Good+Life+has+announced+that+he+will+be+releasing+a+new+solo+album.+The+album+is+called+Middling+Age+and+will+be+out+April+15+via+15+Passenger+Records.+Jayson+Gerycz+of+Cloud+Nothings+played+percussion+on+the+album.+He+has+released+a+video+for+the+first+single+%26quot%3BI+Don%27t+Th..." class="tbr"><b></b></a></div><div id="div-gpt-ad-1442923783286-0" 120x240.html><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1442923783286-0")})</script></div></div></div>
</div>
</article><a rel="prev" href="/article/76712"><div class="nocontent grid-50 mobile-grid-100 prev storynav"><h2>Previous Story</h2><span rel="prev"><i class="fa fa-globe"></i>Tours:  Cancer Bats/Anti-Queens (Canada)</span></div></a><a rel="next" href="/article/76714"><div class="grid-50 mobile-grid-100 next storynav"><h2>Next Story</h2><i class="fa fa-film"></i>Videos:  PasMort: "Le Sorcier de l'Espace"</div></a><div class="relates"><ul><li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/fp-1645541472.jpg);background-size: cover"><a href="/article/76713"><h1>Tim Kasher of Cursive announces solo album, releases video</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/pup-1636471162.jpg);background-size: cover"><a href="/article/75951"><h1>Pup release two new songs, announce 2022 tour</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/fp-1617213226.jpg);background-size: cover"><a href="/article/74371"><h1>Danzig to headline Psycho Las Vegas</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/cloudnothings-1605635807.jpg);background-size: cover"><a href="/article/73999"><h1>Cloud Nothings release "Nothing Without You" video</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/cloudnothings-1605635807.jpg);background-size: cover"><a href="/article/73646"><h1>Cloud Nothings release "The Spirit Of"</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/frontpage/features/fp-1585921527.jpg);background-size: cover"><a href="/article/72325"><h1>FEST 19 announces lineup and plans</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/cursive-1533817926.jpg);background-size: cover"><a href="/article/70315"><h1>Cursive (US)</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/againstme-1531841950.jpg);background-size: cover"><a href="/article/69819"><h1>Against Me! to play four albums in full on tour</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/thegetupkids-1375894343.jpg);background-size: cover"><a href="/article/69765"><h1>The Get Up Kids/ Cloud Nothings/ The Whiffs (US)</h1></a></li>
<li class="grid-20 tablet-grid-20 mobile-grid-50" style="background:linear-gradient(to bottom, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0.0)),url(https://static.punknews.org/images/bands/mewithoutyou-1433954004.jpg);background-size: cover"><a href="/article/69089"><h1>MewithoutYou/Cursive/The Appleseed Cast (US)</h1></a></li>
</ul></div><div id="disqus_thread"></div>
</div><div id="div-gpt-ad-1440508639051-1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-1440508639051-1")})</script></div><footer class="grid-100"><div>
<div class="grid-33">
<div class="logo">
<img alt="Punknews.org" src="https://static.punknews.org/images/icons/blank.gif" width="254" height="48"/></div>
ISSN 1710-5366
</div>
<div class="grid-33">
<a href="/legal">Terms of Use</a>
<a href="/privacy">Privacy Policy</a>
<!-- a rel="external" href="http://www.formspring.me/punknews">Frequently Asked Questions</a -->
<a href="/contact">Contact Us</a>
<a href="/about">About Punknews.org</a>
</div>
<div class="grid-33 social-share">
<a class="igm" title="Punknews.org on Instagram" href="https://instagram.com/punknews"><b></b></a>
<a class="twt" title="Punknews.org on Twitter" href="https://twitter.com/punknews"><b></b></a>
<a class="fbk" title="Punknews.org on Facebook" href="https://www.facebook.com/pages/Punknewsorg/23173142808"><b></b></a>
<a class="tbr" title="Punknews.org on Tumblr" href="https://punknews.tumblr.com/"><b></b></a>
<a class="rss" title="Punknews.org main RSS feed" href="https://static.punknews.org/feeds/punknews.rdf"><b></b></a>
<a class="vim" title="Punknews.org on Vimeo" href="https://vimeo.com/user201096"><b></b></a>
<a class="ytb" title="Punknews.org on YouTube" href="https://www.youtube.com/user/Punknews"><b></b></a>
<a class="pin" title="Punknews.org on Pinterest" href="https://www.pinterest.com/punknews/"><b></b></a>
</div>
<div class="grid-100">
&copy; Copyright 1999-2022 Punknews.org
</div>
</div>
</footer>
</div>
</div>
<script src="//code.jquery.com/jquery-3.6.0.min.js"></script>
<script defer src="https://static.punknews.org/scripts/core.min.js"></script>
<script type="text/javascript">var disqus_shortname="punknews";!function(){var e=document.createElement("script");e.async=!0,e.type="text/javascript",e.src="//"+disqus_shortname+".disqus.com/count.js",(document.getElementsByTagName("HEAD")[0]||document.getElementsByTagName("BODY")[0]).appendChild(e)}()</script><a href="#" class="go-top"><i class="fa fa-chevron-circle-up"></i></a>
</body>
</html>

